Getting started with Structure Manager > Structure Manager interface > Structure Manager menus
Tools menu
| Command | Description |
|---|---|
| Check-In/Out→Check Out | Checks a selected component out of the database. |
| Check-In/Out→Check In | Checks a selected component into the database. |
| Check-In/Out→Cancel Checkout | Cancels a request checkout action. |
| Check-In/Out→Transfer Checkout | Transfers a selected, checked-out component to another user. |
| Check-In/Out→Notification List | Allows you to view or edit the list of users who are informed if the selected component is checked in or checked out. |
| Check-In/Out→Check Out History | Allows you to view the history of checkout actions for the selected component. |
| ID Display Rule→View/Set Current | Allows you to view the ID display rule currently applied to the selected structure or set a different ID display rule. |
| ID Display Rule→Modify Current | Modifies the ID display rule currently applied to the selected structure. |
| ID Display Rule→Create/Edit | Creates a new ID display rule or modify an existing ID rule. |
| Process and Change Selector | Attaches the selected structure to a Workflow process or change. |
| Embedded Software Manager | Allows you to manage binary software in the same way as you manage hard parts. Note: the Embedded Software Solutions (ESS) menu commands must be exposed using Command Suppression. |
| Signal Manager→Associate Signal To | Allows you to associate a signal line in an electromechanical structure to another line as a source, target, transmitter, process variable, or redundant signal. |
| Signal Manager→Remove Signal Association | Removes the association between the selected signal line in an electromechanical structure and another line. |
| Connection Manager→Connect | Connects two selected lines with a revisable or non-revisable connection. |
| Connection Manager→Disconnect | Disconnects the currently selected line with a revisable or non revisable connection to another line. |
| Implemented By→Create Implemented By | Creates Implemented By relationships between the selected line and another line. |
| Implemented By→Remove Implemented By | Removes Implemented By relationships between the selected line and another line. |
| Realized By→Create Realized By | Creates Realized By relationships between the selected line and another line. |
| Realized By→Remove Realized By | Removes Realized By relationships between the selected line and another line. |
| Fix In-Structure Associations→Current Level | Allows you to identify and remove any invalid associations that were created when the structure was manually edited. This command fixes all invalid associations with the selected line. |
| Fix In-Structure Associations→All Levels | Allows you to identify and remove any invalid associations that were created when the structure was manually edited. This command fixes all invalid associations with the selected line and all lines below it. |
| Project→Assign | Assigns the selected structure to a predefined project. |
| Project→Remove | Removes the selected structure from a project to which it is assigned. |
| License→Attach | Attaches an ADA license to the selected workspace object. |
| License→Detach | Detaches the ADA license from the selected workspace object. |
| View/Set Closure Rule for Expansion | Allows you to view the available closure rules and select a rule to limit structure expansions. |
| Trace Link→Traceability | Generates a traceability report for the selected structure. |
| Revision Rule→View/Set Current | Allows you to view or set the revision rule for the currently displayed structure. |
| Revision Rule→Set Date/Unit/End Item | Sets the date, unit number, or end item to configure the structure, if the current rule allows. |
| Revision Rule→Set Override Folder | Sets an override folder to override item revisions that would otherwise be selected by other criteria. |
| Revision Rule→Modify Current | Modifies the current revision rule and apply the modified rule to the current structure. You can save the change if you have write access to the original rule. |
| Revision Rule→Create/Edit | Creates or edits a revision rule. |
| Effectivity→Occurrence Effectivity→View, Edit and Create | Allows you to view, edit, or create occurrence date effectivity data for the occurrence of the selected line. You must have the appropriate permissions to create or edit effectivity data. |
| Effectivity→Occurrence Effectivity→Create on Multiple BOM Lines | Allows you to create occurrence date effectivity data on multiple BOM lines. You must have the appropriate permissions to create or edit effectivity data. |
| Effectivity→Occurrence Effectivity→Calculate Unit Net Effectivity | Allows you to display the occurrence effectivity, unit net effectivity, and unit net EOC information of the selected line. |
| Effectivity→Revision Effectivity | Allows you to view, edit, create, or copy effectivity data for the item revision of the selected line. You must have the appropriate permissions to create or edit effectivity data. |
| Effectivity→Effectivity Mapping | Allows you to view, edit, create, or copy effectivity mapping for an end item. Effectivity mappings are needed if you implement nested effectivity. |
| Variants→Configure Variants | Allows you to configure or edit a variant structure for the selected top-level module. |
| Variants→Only Configure Root | Allows you to set to on to only display options for the top-level module, regardless of the line selected. Set to off to configure the structure for a lower level module. |
| Variants→Search... | Searches for an existing variant item. |
| Variants→Count Modules | Counts the modules defined for the selected variant structure. |
| Variants→Unlink Variant Item | Unlinks a variant item from the generic module item to make changes. |
| Variants→Update Variant Item | If you make structural changes to a generic item and create a new item revision, Teamcenter does not automatically propagate such changes to each associated variant item. Choose this option to make such changes manually. |
| Set/Unset Global Option Item | Allows you to identify the selected item or item revision as a product item with which global options are associated. |
| Incremental Change→Create Context | Allows you to create a new incremental change. Note: this command is visible only if your administrator sets the MoveICCreationToMenu preference to True. If it is not visible, use the Create IC Object button on the incremental change toolbar to create a new incremental change. |
| Incremental Change→Add | Retrospectively creates an add change and attaches it to the active incremental change. |
| Incremental Change→Remove | Retrospectively creates a remove change and attaches it to the active incremental change. |
| Incremental Change→Delete on Object | Establishes a delete change to the attachment. |
| Incremental Change→Create on Object | Establishes a create change to the attachment. |
| Incremental Change→Remove Change | Removes (undoes) changes on the active incremental change. |
| Incremental Change→Incremental Change Baseline | Revises the parent assembly to create an incremental change baseline. |
| Incremental Change→Split | Splits some of the changes from the active incremental change into another existing incremental change. |
| Incremental Change→Intent | Allows you to create a new intent for which the incremental change is valid. An intent represents an alternate solution. |
| Incremental Change→Display icons | Customizes how incremental change icons are displayed and the contexts in which you want to see icons. |
| Arrangements→View/Set | Allows you to view and set the current NX arrangements. |
| Unattached Lines→Clear All | Allows you to clear all the unattached lines in the results of an appearances search. |
| Unattached Lines→Clear Selected | Allows you to clear the currently selected unattached lines in the results of an appearances search. |
| Unattached Lines→Show Parent | Allows you to find the parent of an unattached line in the results of an appearances search. |
| Unattached Lines→Attach | Allows you to reattach unattached lines in the results of an appearances search. |
| All History Lines→Clear All | Clears all history lines in the results of an appearances search. |
| All History Lines→Clear Selected | Clears selected history lines in the results of an appearances search. |
| Validation→Run Validations | Validates attributes of a selected item revision, using third-party software applications, according to criteria set by the system administrator. |
| Validation→View Results | Allows you to view the results of previous validations. |
| Import→Remote | Imports a structure from a remote site in a Multi-Site Collaboration environment. |
| Import→Software Parameters | Allows you to import software parameter data in PLM XML format. |
| Export→Objects | Allows you to export the selected workspace objects through a predefined application interface (AI). |
| Export→To PLMXML | Export the selected structure and its attachments in PLM XML format to a selected export directory. You must choose the appropriate transfer mode for the destination system and selected structure. If you export a structure in which substitute components are defined, the substitutes are also exported. You can export structure changes tracked by incremental changes in PLM XML format. You can specify a suitable closure rule. |
| Export→To Briefcase | Allows you to export a configured product structure in TC XML format. You must choose the appropriate transfer mode for the destination system and selected structure. You can export structure changes tracked by incremental changes in TC XML format. If you track changes with incremental changes, you can optionally export only changes to the configured assembly. Only those objects directly or indirectly affected by incremental changes configured on the structure are exported in full, and other objects are exported as stubs. You can export a structure that is configured with modular variants to TC XML format. |
| Export→Objects to Excel | Exports the selected structure lines to an Excel spreadsheet. |
| Export→Objects to Word | Exports the selected structure lines to a Microsoft Word document. |
| Export→Configured NX Assembly | Exports a product structure that is configured with revision rules and variants to NX in native format. This command is visible only if your administrator sets the TC_ExportConfigUGNXAssembly preference to TRUE and NX is installed on the client machine. |
| Export→Software Parameters | Allows you to export software parameter data in PLM XML format. |
| Stock Selection Rule | Allows you to choose the rule that selects stock material. Typically used in aerospace and defense environments. |
| Send Data To | Sends selected data to another application or external program. Your Teamcenter administrator uses the Business Modeler IDE application to create new application interface types associated with a specific application. Each of these types are available in the Send Data To dialog box. |
| Send Additional Data To | Sends additional data to a running session of the application launched using the Send Data To menu command. |
| Vendor Part Selection Rule | Allows you to apply a predefined vendor parts selection rule to the structure. |
| BOM Grading→Run | Allows you to grade or validate the product structure or subassemblies against predefined criteria. |
| BOM Grading→Show Results | Allows you to view grading results for the select product structure or subassembly. |
| Request Substance Compliance Check | Allows you to request a material substance declaration (MSD) from the supplier of vendor parts for the selected line and its children. |
| Initiate Substance Compliance Check | Runs a compliance check of the selected part or assembly against selected regulations. |
| Apply Exemptions | Allows you to approve the exemption of a part from a selected regulation. |
| Initiate Compliance Results Validation | Allows you to invalidate all substance compliance results that are qualified for invalidation because of expired exemptions. |
| Baseline | Allows you to copy and save your work in progress (WIP) item revisions. During the development of a product design, you may need to share such copies of your working design with other users at the same or different sites. You can also save your design for future reference. |
| Validate Occurrences | Allows you to validate that a selected line and (optionally) any child lines meet the business rules defined by your administrator for structure edits. |
| Manage Global Alternates | Allows you to define global alternates and a preferred alternate for the selected component. |
| Compare... | Compares two product structures (or different revisions of the same structure) in separate windows. |
| Clear Compare | Clears the results of comparing two product structures. |
| Graphical BOM Compare | Compares two revisions of a part or assembly and examine the difference in the Viewer pane. You cannot use this command to compare multilevel structures. |
| Intermediate Data Capture | Saves the current structure configuration in PLM XML format on your system for later retrieval or transfer. An Intermediate Data Capture (IDC) is a PLM XML file that contains the definitions of all the objects in the captured structure. |
| Markup→Markup Mode | Turns markup mode on or off. |
| Markup→Show Markup View | If the selected line has an associated markup, allows you to view its properties. |
| Markup→Delete Markup (this level) | Deletes the active markup for the selected line. |
| Markup→Apply Markup (this level) | Applies uncommitted changes in the markup associated with the current line. Any markups associated with lines below the current selection are not committed. |
| Markup→Apply Markup (all levels) | Applies uncommitted changes in the markup to the structure, starting from the top line. |
| Markup→Validate Access to Apply Markups (all levels) | Identifies if you have the necessary write access to the BOM view revision (BVR) to commit changes in a markup associated with any line below the structure's top line. |
| Site Check In/Out→Check Out to Site | If you are working with Multi-Site Collaboration, allows you to check out the selected object to a chosen site. |
| Site Check In/Out→Check in from Site | If you are working with Multi-Site Collaboration, allows you to check in the selected object from a chosen site. |
| Roll up Report→Create | Allows you to create a rollup report. |
| Roll up Report→View | Allows you to view a rollup report. |
| Roll up Report→Templates | Allows you to manage templates for a rollup report. |
Note: You may see additional commands in this menu if optional features are installed at your site. For example, if you install Teamcenter Integration for NX, an Export NX Assembly command is available. Similarly, some commands are hidden unless a preference setting is changed. For information about any additional commands, see the documentation for the optional feature or contact your Teamcenter administrator.
Source: https://docs.sw.siemens.com/en-US/doc/282219420/PL20251212545240207.pse/xid374322 · retrieved 2026-07-11