TeamcenterKnowledge

Browsing product structure > Open a structure

Open a structure

You can open a structure by any of the following methods: Click the Open by Name button Use this method to open an existing structure. Enter strings for the ID or the name of the items you want to open. Double-click the item you want to open.

Note If the item has several revisions, the window's current revision rule determines the revision opened. If you want to open a specific revision, locate the revision in another application and open it by sending it to Structure Manager or by dragging-and-dropping. Click the MRU (Most Recently Used) button This button opens any of the last four top-level structures you opened. This list is saved across sessions, and is an easy way to reopen structures you were previously working on. Click the item revision you want to open.

Note You can configure the number of entries shown in the MRU list by right-clicking the button and moving the slider to the desired number. Use the clipboard This is useful for opening multiple structures from another application, for example, My Teamcenter, as follows: Copy the items or item revisions to the clipboard in the other application, then go to Structure Manager. Click the Clipboard button to display the copied objects and choose the items or item revisions you want to open in Structure Manager. Repeat the previous step as necessary. You can only open one item or item revision at a time. Open from another application using the Send To command This method is useful if you have a reference to the required top-level structure (which may be an item, item revision, BOM view or BOM view revision), in another application. Place the cursor over the object you want to open in the other application. Right-click the object to display the structure line shortcut menu and choose Send To. Teamcenter displays a list of the destination applications (for example, Multi-Structure Manager and My Teamcenter). Click the desired application. If the object is an item or BOM view, Teamcenter typically uses the default revision rule to determine the revision opened, as follows. When you send a structure to Structure Manager from My Teamcenter, Teamcenter opens Structure Manager, loads the structure, and then applies the default revision rule. If an empty Structure Manager window is already open, Teamcenter loads the structure into it, and then applies the default revision rule. However, if a Structure Manager window is already open and contains a configured structure, Teamcenter loads the structure into it, and then applies the revision rule used to configure the previously-displayed structure. In Teamcenter Rich Client, when you open Structure Manager, a Structure Manager view is displayed by default. However, if you close this view, Teamcenter does not open another Structure Manager view. Therefore, to perform any operation, such as dragging an item, you need to reopen the Structure Manager view by selecting Window > Show View > Structure Manager. If the item has a revision rule applied with Has Occurrence Type (MEAssemble), then you must select the item revision and choose Send To > Structure Manager. If you select the item and choose Send To > Structure Manager, the system displays an error saying that there is No Configured Revision. Choose the File→Open command This is useful for opening a new Structure Manager window on a subassembly. Select the line for which you want to open a new window and choose File→Open. Drag and drop Drag the line representing the structure from another application such as My Teamcenter and drop it into the empty navigation tree pane. Click a link Click a link in the Open Items, History, or Favorites sections of the navigation pane. If the current Structure Manager window already contains an opened structure, all of these methods create a new Structure Manager window. You can open two structures side-by-side by clicking the Split Window button . When you do this, Structure Manager associates the structures for the current session. You cannot then open another structure into the current split window configuration or open one of the previously open structures in a different unsplit window. To achieve these results, you must first unsplit the window by clicking again or close the structures. To reduce the amount of time-consuming database interaction required to view a product structure, the components of an assembly are not loaded from the database until you expand the assembly. The first expansion may be slow, but subsequent expansion and contractions do not require data from the database and are therefore faster. When you have two structures open in the same window and try to close the window, Teamcenter displays a confirmation dialog requesting confirmation. For example, this occurs if you try to close the window in Structure Manager and NX is using the same window.

Source: https://docs.sw.siemens.com/documentation/external/PL20251212545240207/en-US/tc_help/pse/xwp1737253321731/azt1737253323186/bps_openingstruct.html · retrieved Sat Jul 11 2026 00:00:00 GMT+0000 (Coordinated Universal Time)