TeamcenterKnowledge

Building and editing product structure > Restructuring and editing the product structure

Move a node to another branch

You can move a selected node from one branch to another. All substructure and occurrence data moves with the node.

Procedure Move a node using any of the following methods: Cut and paste using the Edit→Cut and Edit→Paste menu commands. Cut and paste using the Ctrl+X and Ctrl+V shortcut keys.

Caution Do not try to move a node by dragging the line to its new position. Teamcenter performs a copy action when you drag a line. Teamcenter displays the Paste dialog box. Do one or more of the following: Change the item ID and revision ID. Change the view type, if applicable. Select if the line should be pasted as a component of the selected assembly line, as a substitute for the selected line, or as a new level above the selected line. Specify the number of occurrences, quantity per occurrence, and find number. Click OK or Apply to complete moving the line.

Caution If you cut a line and edit tracking is enabled, the line is displayed in red with a strike-through until you commit the edits. Do not attempt to edit or work with this line, or you may obtain unpredictable results. If you want to edit or work with a line that is marked as cut, revert changes to the line by choosing Edit→Revert Edit first. Similarly, do not edit or work with a marked line in another structure editor such as Multi-Structure Manager. Always complete and save your work on the structure before you open it in another structure editor.

Note In most cases, associations between objects (such as Connected To relations) are correctly maintained or are reassociated. However, after editing a mechatronics structure, you should always choose the Fix In-Structure Associations command to identify any invalid associations. Any lines representing GDEs are renumbered after moving a node. If you move both the primary and secondary lines of a mechatronics relation out of context, the relation is removed. However, if you move both the primary and secondary lines of a mechatronics relation to any level below the context, the relation is not removed. It is listed in the Fix In-Structure Associations dialog box when you choose Tools→Fix In-Structure Associations, allowing you to fix the invalid association. If you remove the secondary line of a mechatronics relation out of context, the relation itself is removed. Refresh the primary line to see the updated BOM column properties. If the line has an associated variant condition and you move it out of the scope of the option referenced in the variant condition, the variant condition is not retained. If you move a node that has absolute occurrence overrides out of the scope of the context of the overrides, the system does not retain the override values after the move.

Source: https://docs.sw.siemens.com/documentation/external/PL20251212545240207/en-US/tc_help/pse/jdx1737253331775/xwz1737253335576/build_movenode.html · retrieved Sat Jul 11 2026 00:00:00 GMT+0000 (Coordinated Universal Time)